On 10/04/2012 17:24, Michael Matz wrote: > Hi, > > On Tue, 10 Apr 2012, Xinliang David Li wrote: > >>>>> exp->as_component_ref().get_field() .. > >>> Actually it's not questionable. The above stuff is _horrible_. >> Specifics please. It is _horrible_ because you are more used to the >> existing way and the new style does not match your taste or they are >> very hard to understand and use? > > Your style (I wouldn't call it The New Style) is visually distracting, and > therefore harder to understand and use, longer to write and full of > syntactic noise without any whitespace. Quite frankly, how anyone could > ever say that > > exp->as_component_ref().get_field() > > is easier to read/write/use than > > GET_FIELD_DECL (exp) > > (say when we #define GET_FIELD_DECL(x) TREE_OPERAND(x,1)), with or without > all-caps, is completely beyond me. I pretty much hope that we never see > the ugliness of the first way in GCCs code base. Even in C++ it's > possible to write non-spaghetti code.
So isn't #define GET_FIELD_DECL(exp) ((exp)->as_component_ref().get_field()) the simple solution to that one? cheers, DaveK