On Fri, Sep 21, 2007 at 04:53:38PM +0200, Tomas Svensson wrote:

> (define_expand "bleu"
>  [(use (match_operand 0 "" ""))]
>  ""
>  "expand_branch (LEU, operands[0]); DONE;")
> 
> which is heavily inspired by the or32 port of version 3.4.4, as is
> expand_branch().

> But this should not need a matching insn, since it ends in a DONE;,
> right?

   Wrong. Everything emitted by an expander needs to be matched by an insn
pattern.

> Or am I missing something again?

   The construct

(define_insn "name_not_beginning_with_asterix"
...

probably should have been

(define_expand_and_insn "name_not_beginning_with_asterix"
...

for clarity.

-- 
Rask Ingemann Lambertsen
Danish law requires addresses in e-mail to be logged and stored for a year

Reply via email to