On Thu, Jun 09, 2005 at 05:31:06PM -0400, Daniel Berlin wrote: > > > On Thu, 9 Jun 2005, Pat Haugen wrote: > > >[EMAIL PROTECTED] wrote on 06/09/2005 02:43:37 PM: > > > >>cc1: warnings being treated as errors > >>/home/pthaugen/work/src/mainline/gcc/gcc/config/rs6000/rs6000.c:12538: > >>warning: âÿÿÿÿrs6000_invalid_within_doloopâÿÿÿÿ defined but not > >>used > > > >ChangeLog looks odd on this, Adrian changed the name of prototype and then > >later Daniel came along and fixed prototype of "old" name. > > > >2005-06-09 Daniel Berlin <[EMAIL PROTECTED]> > > > > * config/rs6000/rs6000.c: (rs6000_insn_valid_within_doloop): Fix > > prototype. > > Before i committed this, we had > > "static bool rs6000_invalid_within_doloop > > static const char * > rs6000_invalid_within_doloop .... > " > > I had updated rs6000.c repeatedly to make sure i wasn't missing something. > > I simply made the prototype at the top match the function as it actually > exists in the source file. > > "Defined but not used" means it exists in the source file but isn't > actually used, which is a different bug :) >
Argh, these two updates were completely wrong: -static bool rs6000_insn_valid_within_doloop (rtx); +static bool rs6000_invalid_within_doloop (rtx); -#define TARGET_INSN_VALID_WITHIN_DOLOOP rs6000_insn_valid_within_doloop +#define TARGET_INSN_VALID_WITHIN_DOLOOP rs6000_invalid_within_doloop They should have looked like that: -static bool rs6000_insn_valid_within_doloop (rtx); +static const char *rs6000_invalid_within_doloop (rtx); -#undef TARGET_INSN_VALID_WITHIN_DOLOOP -#define TARGET_INSN_VALID_WITHIN_DOLOOP rs6000_insn_valid_within_doloop +#undef TARGET_INVALID_WITHIN_DOLOOP +#define TARGET_INVALID_WITHIN_DOLOOP rs6000_invalid_within_doloop Looking at the current sources, it seems like you have fixed that already. Thank you! I'm very much sorry for the inconvenience! Adrian