"Dave Korn" <[EMAIL PROTECTED]> writes:

>   I'm basically in agreement with you here, and just want to suggest you can
> avoid an awful lot of code duplication by doing something like
>
> #ifdef REG_OK_STRICT
> #define ${CPU}_IS_STRICT 1
> #else 
> #define ${CPU}_IS_STRICT 0
> #endif

This idiom is in common use already, and from the point of view of the
conversion, I think it'll make things *harder*, because - just like
any macro whose value depends on REG_OK_STRICT and is used in other
macros that aren't defined in #ifdef REG_OK_STRICT blocks - it makes
it impossible to grep for REG_OK_STRICT and find all affected macros.

Now, this is a preexisting condition, but I'm really not wanting to
make it worse.

zw

Reply via email to