On Fri, Dec 19, 2014 at 08:19:17AM +0000, Xingxing Pan wrote: > Hi, > > This patch expands the arm types neon_logic<q>, neon_from_gp<q> and > neon_to_gp<q>. This change mainly suits to marvell-whitney cores, and > will not affect other arm core's pipeline description. > > neon_logic<q> is expanded to neon_logic_reg<q> and neon_logic_imm<q>, > corresponding respectively to the predicates s_register_operand and > imm_for_neon_logic_operand. > > neon_from/to_gp<q> is expanded to neon_reg_from/to_gp<q> and > neon_lane_from/to_gp<q>, decided by whether the neon side is a single > register or a register lane.
Sorry to ask for churn here, but the naming scheme for lane operations elsewhere in types.md seems to be: neon_<operation><_scalar><_q> as in: ; neon_mul_s_scalar ; neon_mul_s_scalar_q I think the types you are introducing should be: neon_from_gp_scalar<q> neon_to_gp_scalar<q> Thanks, James