On 09/04/14 19:52, David Malcolm wrote:
gcc/
* except.c (for_each_eh_label): Within param "callback",
strengthen param from rtx to rtx_code_label *. Strengthen local
"lab" from rtx to rtx_code_label *. Remove redundant check on
LABEL_P (lab), since this is known from the type rtx_code_label *.
* except.h (for_each_eh_label): Within param "callback",
strengthen param from rtx to rtx_code_label *.
* reload1.c (set_initial_eh_label_offset): Strengthen param
"label" from rtx to rtx_code_label *.
OK.
{
- rtx lab = lp->landing_pad;
- if (lab && LABEL_P (lab))
+ rtx_code_label *lab = lp->landing_pad;
+ if (lab)
Though I do wonder what in the world LAB could be here other than a
label... Maybe someone was just being paranoid. If anything were to
show up here other than a label, I'd call that a bug. Though presumably
that can't happen now without someone playing games with a cast :-)
Jeff