On Mon, Apr 14, 2014 at 10:18 AM, Eric Botcazou <ebotca...@adacore.com> wrote: > Hi, > > the 'loop' structure in cfgloop.h contains two consecutive fields: > > /* True if we should try harder to vectorize this loop. */ > bool force_vect; > > /* True if this loop should never be vectorized. */ > bool dont_vectorize; > > Not clear why someone thought that the name discrepancy would be helpful so > this patch standardizes the spelling (in favor of 'vectorize', as in the long > existing flag_tree_loop_vectorize switch). > > Tested on x86_64-suse-linux, OK for the mainline?
Ok. Thanks, Richard. > > 2014-04-14 Eric Botcazou <ebotca...@adacore.com> > > * cfgloop.h (struct loop): Rename force_vect into force_vectorize. > * function.h (struct function): Rename has_force_vect_loops into > has_force_vectorize_loops. > * lto-streamer-in.c (input_cfg): Adjust for renaming. > (input_struct_function_base): Likewise. > * lto-streamer-out.c (output_cfg): Likewise. > (output_struct_function_base): Likewise. > * omp-low.c (expand_omp_simd): Likewise. > * tree-cfg.c (move_sese_region_to_fn): Likewise. > * tree-if-conv.c (ifcvt_can_use_mask_load_store): Likewise. > (version_loop_for_if_conversion): Likewise. > (tree_if_conversion): Likewise. > (main_tree_if_conversion): Likewise. > (gate_tree_if_conversion): Likewise. > * tree-inline.c (copy_loops): Likewise. > * tree-ssa-loop-ivcanon.c (tree_unroll_loops_completely_1): Likewise. > * tree-ssa-loop.c (tree_loop_vectorize): Likewise. > * tree-ssa-phiopt.c (tree_ssa_phiopt_worker): Likewise. > * tree-vect-loop.c (vect_estimate_min_profitable_iters): Likewise. > * tree-vectorizer.c (vectorize_loops): Likewise. > * tree-vectorizer.h (unlimited_cost_model): Likewise. > > > -- > Eric Botcazou