On 09/20/2013 02:13 AM, Richard Biener wrote:
On Thu, Sep 19, 2013 at 8:11 PM, Richard Sandiford
<rdsandif...@googlemail.com> wrote:
Michael Matz <m...@suse.de> writes:
What's the benefit of reading and writing such noisy lines? :
*out_mode = mode_;
mode_ = GET_MODE_WIDER_MODE (mode_);
count_++;
The uglification merely makes code harder to write and read, it should be
used in cases where you _don't_ want developers to write such names.
Heh. Since it's my code being used as the example here: I also find it
very ugly FWIW. I only added the underscores because that's what the
conventions said.
But we're never going to get consensus on this kind of thing. E.g. I
know some people really hate the GNU formatting style (although I very
much like it). So I just held my nose while writing the patch.
Btw, I've come around multiple coding-styles in the past and I definitely
would prefer m_mode / m_count to mark members vs. mode_ and count_.
(and s_XXX for static members IIRC).
That would be fine with me. If you want to propose this as a change to
our coding standards, I'd support it. Then it's just a matter of
changing the existing code.. Sigh..
jeff