Hello! The patch replaces open-coded INTEGER_CLASS_P macro with its definition from i386.h
2013-02-08 Uros Bizjak <ubiz...@gmail.com> * config/i386/i386.c (ix86_spill_class): Use INTEGER_CLASS_P macro. Bootstrapped and regression tested on x86_64-pc-linux-gnu {,-m32}, with additional configure flags "--with-arch=corei7 --with-cpu=corei7". Committed as obvious to mainline SVN. Index: config/i386/i386.c =================================================================== --- config/i386/i386.c (revision 195880) +++ config/i386/i386.c (working copy) @@ -42083,9 +42083,8 @@ ix86_spill_class (reg_class_t rclass, enum machine_mode mode) { if (TARGET_SSE && TARGET_GENERAL_REGS_SSE_SPILL && ! TARGET_MMX - && hard_reg_set_subset_p (reg_class_contents[rclass], - reg_class_contents[GENERAL_REGS]) - && (mode == SImode || (TARGET_64BIT && mode == DImode))) + && (mode == SImode || (TARGET_64BIT && mode == DImode)) + && INTEGER_CLASS_P (rclass)) return SSE_REGS; return NO_REGS; }