> +bool
> +is_frac_vlmul_p (machine_mode mode)
> +{
> + switch (get_vlmul (mode))
> + {
> + case LMUL_1:
> + case LMUL_2:
> + case LMUL_4:
> + case LMUL_8:
> + return false;
> + case LMUL_F8:
> + case LMUL_F4:
> + case LMUL_F2:
> + return true;
> + default:
> + break;
> + }
> +
> + gcc_unreachable ();
> +}
The only concern I have here is that we might want to (prematurely) optimize
this to something like return get_vlmul > 4; rather than a full-blown switch
case (thinking that the dynamic filter is being called very often).
On the other hand your version is more readable.
I guess easy enough to change later, so OK.
--
Regards
Robin