Hi gcc-patches mailing list, Christopher Bazley via Sourceware Forge <[email protected]> has requested that the following forgejo pull request be published on the mailing list.
Created on: 2026-06-23 10:46:06+00:00 Latest update: 2026-06-23 10:47:54+00:00 Changes: 1 changed files, 8 additions, 8 deletions Head revision: chris.bazley/gcc ref horrible_confusion commit c9c52eb74ccd7908f4dee57b5778206783fc4f1d Base revision: gcc/gcc-TEST ref trunk commit 6f7c038eee71e519571df5741413f0547fbe85a7 r16-7145-g6f7c038eee71e5 Merge base: 6f7c038eee71e519571df5741413f0547fbe85a7 Full diff url: https://forge.sourceware.org/gcc/gcc-TEST/pulls/182.diff Discussion: https://forge.sourceware.org/gcc/gcc-TEST/pulls/182 Requested Reviewers: 'nelts' is not the number of encoded elements in a VECTOR_CST; it is the number of patterns. Sometimes those interpretations coincide, as in the case of fixed length vector types (for which the number of elements per pattern is one), but not always. 'step' is not the step between the second and third element of a stepped pattern; it is the number of elements per pattern. This has led to confusion on the mailing list. Both variables are hereby renamed. gcc/ChangeLog: * tree.cc (build_vector_from_ctor): Rename variables. Changed files: - M: gcc/tree.cc Christopher Bazley (1): Fix confusing variable names in build_vector_from_ctor gcc/tree.cc | 16 ++++++++-------- 1 file changed, 8 insertions(+), 8 deletions(-) -- 2.54.0
