Fix std.cc.in to export the new name for std::dynamic_format.
Also update the checks against __cpp_lib_format to use the new value.
This doesn't matter in practice, but strictly speaking the right value
for defining std::dynamic_format is 202603 not 202311 (which was the
macro value for the old name, std::runtime_format).
libstdc++-v3/ChangeLog:
* include/std/format (dynamic_format): Check new value for
feature test macro.
* src/c++23/std.cc.in (dynamic_format): Fix export to use new
name.
---
This was missing from the commit to rename it.
libstdc++-v3/include/std/format | 2 +-
libstdc++-v3/src/c++23/std.cc.in | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/libstdc++-v3/include/std/format b/libstdc++-v3/include/std/format
index 2bcd06822b75..eca5bd213aa0 100644
--- a/libstdc++-v3/include/std/format
+++ b/libstdc++-v3/include/std/format
@@ -195,7 +195,7 @@ namespace __format
= basic_format_string<wchar_t, type_identity_t<_Args>...>;
#endif
-#if __cpp_lib_format >= 202311L // >= C++26
+#if __cpp_lib_format >= 202603L // >= C++26
[[__gnu__::__always_inline__]]
inline __format::_Dynamic_format_string<char>
dynamic_format(string_view __fmt) noexcept
diff --git a/libstdc++-v3/src/c++23/std.cc.in b/libstdc++-v3/src/c++23/std.cc.in
index 1e174b85af1b..41a9e6c205af 100644
--- a/libstdc++-v3/src/c++23/std.cc.in
+++ b/libstdc++-v3/src/c++23/std.cc.in
@@ -1369,8 +1369,8 @@ export namespace std
using std::formatter;
using std::make_format_args;
using std::make_wformat_args;
-#if __cpp_lib_format >= 202311L // >= C++26
- using std::runtime_format;
+#if __cpp_lib_format >= 202603L // >= C++26
+ using std::dynamic_format;
#endif
using std::vformat;
using std::vformat_to;
--
2.53.0