On 4/11/25 1:04 PM, Alexandre Oliva wrote: > --- a/gcc/testsuite/gcc.target/powerpc/block-cmp-8.c > +++ b/gcc/testsuite/gcc.target/powerpc/block-cmp-8.c > @@ -1,6 +1,6 @@ > /* { dg-do run { target ilp32 } } */ > /* { dg-options "-O2 -mpowerpc64" } */ > -/* { dg-require-effective-target has_arch_ppc64 } */ > +/* { dg-require-effective-target powerpc64 } */ > /* { dg-timeout-factor 2 } */
I agree has_arch_ppc64 is a compile only test and won't help us not execute on 32-bit only hw and that the powerpc64 target test is the test you want. That said, I hate the name "powerpc64" and it should probably be renamed to "powerpc64_hw" to be more clear about what it's testing. That said, that should be done in a separate patch. Peter