Hello! This patch fixes a trivial oversight in the name of "or" family of sync functions.
2012-06-12 Uros Bizjak <ubiz...@gmail.com> * config/ia64/sync.md (fetchop_name): Change ior attribute to "or". Tested on ia64-unknown-linux-gnu. Is it still OK to squeeze this trivial one-liner to 4.7 branch? Uros. Index: config/ia64/sync.md =================================================================== --- config/ia64/sync.md (revision 188475) +++ config/ia64/sync.md (working copy) @@ -28,7 +28,7 @@ (define_code_iterator FETCHOP [plus minus ior xor and]) (define_code_attr fetchop_name - [(plus "add") (minus "sub") (ior "ior") (xor "xor") (and "and")]) + [(plus "add") (minus "sub") (ior "or") (xor "xor") (and "and")]) (define_expand "mem_thread_fence" [(match_operand:SI 0 "const_int_operand" "")] ;; model