On Tue, 12 Dec 2023, Jakub Jelinek wrote: > On Mon, Dec 11, 2023 at 05:00:50PM -0500, Jason Merrill wrote: > > In discussion of PR71093 it came up that more clobber_kind options would be > > useful within the C++ front-end. > > > > gcc/ChangeLog: > > > > * tree-core.h (enum clobber_kind): Rename CLOBBER_EOL to > > CLOBBER_STORAGE_END. Add CLOBBER_STORAGE_BEGIN, > > CLOBBER_OBJECT_BEGIN, CLOBBER_OBJECT_END. > > * gimple-lower-bitint.cc > > * gimple-ssa-warn-access.cc > > * gimplify.cc > > * tree-inline.cc > > * tree-ssa-ccp.cc: Adjust for rename. Doesn't build_clobber_this in the C++ front-end need to be adjusted too? I think it is used to place clobbers at start of the ctor (should be CLOBBER_OBJECT_BEGIN in the new nomenclature) and end of the dtor (i.e. CLOBBER_OBJECT_END). Alexander
- Re: [PATCH] c++: End lifetime of objects in constexpr af... Alexander Monakov
- Re: [PATCH] c++: End lifetime of objects in constex... Richard Biener
- Re: [PATCH] c++: End lifetime of objects in constexpr af... Jason Merrill
- Re: [PATCH] c++: End lifetime of objects in constex... Richard Biener
- Re: [PATCH] c++: End lifetime of objects in con... Jason Merrill
- Re: [PATCH] c++: End lifetime of objects in... Richard Biener
- Re: [PATCH] c++: End lifetime of object... Marek Polacek
- Re: [PATCH] c++: End lifetime of object... Jason Merrill
- Re: [PATCH] c++: End lifetime of object... Marek Polacek
- Re: [PATCH] c++: End lifetime of object... Jakub Jelinek
- Re: [PATCH] c++: End lifetime of object... Alexander Monakov
- Re: [PATCH] c++: End lifetime of object... Jakub Jelinek
- Re: [PATCH] c++: End lifetime of object... Jason Merrill
- Re: [PATCH] c++: End lifetime of object... Jason Merrill
- Re: [PATCH] c++: End lifetime of object... Jason Merrill
- [pushed 1/4] c++: copy location to AGGR... Jason Merrill
- [pushed 3/4] c++: fix in-charge parm in... Jason Merrill
- [pushed 4/4] c++: End lifetime of objec... Jason Merrill
- [pushed 2/4] c++: constant direct-initi... Jason Merrill
- Re: [pushed 1/4] c++: copy location to ... Patrick Palka
- [pushed] c++: TARGET_EXPR location in d... Jason Merrill