From: Ronan Desplanques <desplanq...@adacore.com> This patch does not change the behavior of the compiler, but is intended to improve readability. It seizes an opportunity to move a variable declaration to a smaller scope, so that it's clearer that the variable is not used outside of that scope.
gcc/ada/ * sem_ch3.adb (Replace_Type): Reduce span of variable. Tested on x86_64-pc-linux-gnu, committed on master. --- gcc/ada/sem_ch3.adb | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/gcc/ada/sem_ch3.adb b/gcc/ada/sem_ch3.adb index a0783195b8b..c8af679b404 100644 --- a/gcc/ada/sem_ch3.adb +++ b/gcc/ada/sem_ch3.adb @@ -15901,7 +15901,6 @@ package body Sem_Ch3 is procedure Replace_Type (Id, New_Id : Entity_Id) is Id_Type : constant Entity_Id := Etype (Id); - Acc_Type : Entity_Id; Par : constant Node_Id := Parent (Derived_Type); begin @@ -15913,6 +15912,7 @@ package body Sem_Ch3 is if Ekind (Id_Type) = E_Anonymous_Access_Type then declare + Acc_Type : Entity_Id; Desig_Typ : Entity_Id := Designated_Type (Id_Type); begin -- 2.40.0