Hi! I'd like to ping patches 2 through 6 of this series. Much obliged! Thanks, Bill
On 12/6/21 2:49 PM, Bill Schmidt via Gcc-patches wrote: > Hi! > > Now that the new built-in function support is all upstream and enabled, it > seems safe and prudent to remove the old code to avoid confusion. I broke > this > up to the extent possible, but a couple of patches are still pretty large. > > David Edelsohn found that I had broken some C++ library functions for AIX, and > his fix for that required me to re-spin the patches. I also generated the > diff > with a more efficient algorithm to reduce the patch size. Otherwise this > series is identical to V1. > > Thanks! > Bill > > Bill Schmidt (6): > rs6000: Remove new_builtins_are_live and dead code it was guarding > rs6000: Remove altivec_overloaded_builtins array and initialization > rs6000: Rename rs6000-builtin-new.def to rs6000-builtins.def > rs6000: Remove rs6000-builtin.def and associated data and functions > rs6000: Rename functions with "new" in their names > rs6000: Rename arrays to remove temporary _x suffix > > gcc/config/rs6000/darwin.h | 8 +- > gcc/config/rs6000/rs6000-builtin.def | 3350 ----- > ...00-builtin-new.def => rs6000-builtins.def} | 0 > gcc/config/rs6000/rs6000-c.c | 1266 +- > gcc/config/rs6000/rs6000-call.c | 11964 +--------------- > gcc/config/rs6000/rs6000-gen-builtins.c | 115 +- > gcc/config/rs6000/rs6000-internal.h | 2 +- > gcc/config/rs6000/rs6000-protos.h | 3 - > gcc/config/rs6000/rs6000.c | 334 +- > gcc/config/rs6000/rs6000.h | 58 - > gcc/config/rs6000/t-rs6000 | 7 +- > 11 files changed, 224 insertions(+), 16883 deletions(-) > delete mode 100644 gcc/config/rs6000/rs6000-builtin.def > rename gcc/config/rs6000/{rs6000-builtin-new.def => rs6000-builtins.def} > (100%) >