Hi! On Thu, Oct 14, 2021 at 09:49:30AM +0200, Martin Liška wrote: > gcc/ChangeLog: > * config/rs6000/rs6000.c (rs6000_override_options_after_change): > Do not set flag_rename_registers, it's already default behavior.
It defaults to *off*? frename-registers Common Var(flag_rename_registers) Optimization EnabledBy(funroll-loops) Perform a register renaming optimization pass. > Use EnabledBy for unroll_only_small_loops. > * config/rs6000/rs6000.opt: Use EnabledBy for > unroll_only_small_loops. > --- > gcc/config/rs6000/rs6000.c | 7 +------ > gcc/config/rs6000/rs6000.opt | 2 +- > 2 files changed, 2 insertions(+), 7 deletions(-) > > diff --git a/gcc/config/rs6000/rs6000.c b/gcc/config/rs6000/rs6000.c > index acba4d9f26c..40146179e06 100644 > --- a/gcc/config/rs6000/rs6000.c > +++ b/gcc/config/rs6000/rs6000.c > @@ -3472,13 +3472,8 @@ rs6000_override_options_after_change (void) > /* Explicit -funroll-loops turns -munroll-only-small-loops off, and > turns -frename-registers on. */ > if ((OPTION_SET_P (flag_unroll_loops) && flag_unroll_loops) > - || (OPTION_SET_P (flag_unroll_all_loops) > - && flag_unroll_all_loops)) > + || (OPTION_SET_P (flag_unroll_all_loops && flag_unroll_all_loops))) That doesn't do what the changelog said, and it is not obvious at all that this is correct? Maybe this works with the current implementation of that macro (I assume you tested it works :-) ), but that is not something you can depend on. This expands to global_options_set.x_flag_unroll_all_loops && flag_unroll_all_loops just like the previous code did, but that one was obvious, and this is not. > { > - if (!OPTION_SET_P (unroll_only_small_loops)) > - unroll_only_small_loops = 0; > - if (!OPTION_SET_P (flag_rename_registers)) > - flag_rename_registers = 1; > if (!OPTION_SET_P (flag_cunroll_grow_size)) > flag_cunroll_grow_size = 1; > } > diff --git a/gcc/config/rs6000/rs6000.opt b/gcc/config/rs6000/rs6000.opt > index 9d7878f144a..faeb7423ca7 100644 > --- a/gcc/config/rs6000/rs6000.opt > +++ b/gcc/config/rs6000/rs6000.opt > @@ -546,7 +546,7 @@ Target Undocumented Var(rs6000_optimize_swaps) Init(1) > Save > Analyze and remove doubleword swaps from VSX computations. > > munroll-only-small-loops > -Target Undocumented Var(unroll_only_small_loops) Init(0) Save > +Target Undocumented Var(unroll_only_small_loops) Init(0) Save > EnabledBy(funroll-loops) Your patches cannot apply. Please send them non-wordwrapped. This isn't the endpoint of the changes here I hope? The macro games make everything less readable (so, harder to change) and more fragile. Segher