Hi! On Mon, Aug 24, 2020 at 03:53:44PM +0800, HAO CHEN GUI wrote: > abs_jump_table = (!CASE_VECTOR_PC_RELATIVE > && > !targetm.asm_out.generate_pic_addr_diff_vec ()) ? 1 : 0;
x = y ? 1 : 0; is the same as x = y; if y is already only 0 or 1, and otherwise it is x = !!y; You can also write this as an "if", that often is more readable. > @@ -2491,9 +2491,17 @@ final_scan_insn_1 (rtx_insn *insn, FILE *file, int > optimize_p ATTRIBUTE_UNUSED, > if (! JUMP_TABLES_IN_TEXT_SECTION) > { > int log_align; > + bool reloc; > +extern section *default_function_rodata_section (tree, bool reloc); > +extern section *default_no_function_rodata_section (tree, bool reloc); "reloc" is an int elsewhere, and can have 4 values. And you have to interact with that code (mostly in varasm.c), so don't use the same name meaning something else? You need an RTL maintainer or global maintainer to review this... Segher