> Hi Richard, > > Thanks for the review. > > On 04/08/16 17:26, Richard Biener wrote: > >On Thu, Aug 4, 2016 at 6:12 AM, kugan <kugan.vivekanandara...@linaro.org> > >wrote: > >>Hi, > >> > >>During IPA-VRP implementation, I realized that we don't support streaming > >>wide_int in LTO. Attached patch does this. Tested with IPA-VRP. Is this OK > >>for trunk if bootstrap and regression testing is fine. > > > >Hmm, those functions belong to data-streamer-{in,out}.c and data-streamer.h > >and should be named streamer_write_wide_int / streamer_read_wide_int. > > > >Note that we already have (non-exported) streamer_write_wi / streamer_read_wi > >which operate on widest_ints. Those also reside in lto-streamer-{in,out}.c > >and > >should be moved to data-streamer.h (and be renamed to > >streamer_write_widest_int). > > I have now streamer_write_wide_int and streamer_write_widest_int. > Similarly for reading. There is lot of similarity. I am not very > familiar with wide_int so kept it that way. Is this OK now? > > Thanks, > Kugan > > gcc/ChangeLog: > > 2016-08-04 Kugan Vivekanandarajah <kug...@linaro.org> > > * data-streamer-in.c (streamer_read_wide_int): New. > (streamer_read_widest_int): Renamed function. > * data-streamer-out.c (streamer_write_wide_int): New > (streamer_write_widest_int): Renamed function.
I wondered, given we do C++ now, if we don't want to just have stream_in/stream_out member functions for our classes and/or use just one function name for all of them so one does not need to look up somewhat irregular function names. I find LTO streaming API very hard to memorize and use without constantly looking up existing code. Honza