On Sunday 28 August 2011 22:36:28, Kai Tietz wrote: > +#ifdef HAVE_ENOSPC > + no_space_on_device = ENOSPC, > +#endif
> no_such_device = ENODEV, > @@ -96,12 +100,18 @@ > -// not_supported = ENOTSUP, > +#ifdef HAVE_ENOTSUP > + not_supported = ENOTSUP, > +#endif > -// operation_not_permitted = EPERM, > +#ifdef HAVE_EPERM > + operation_not_permitted = EPERM, > +#endif These now have the HAVE_ prefix. > -// operation_would_block = EWOULDBLOCK, > +#ifdef EWOULDBLOCK > + operation_would_block = EWOULDBLOCK, > +#endif > // text_file_busy = ETXTBSY, > -// timed_out = ETIMEDOUT, > +#ifdef ETIMEDOUT > + timed_out = ETIMEDOUT, > +#endif While these two didn't get the HAVE_... prefix. Was that intended? -- Pedro Alves