On Tue, Jun 28, 2016 at 02:13:24PM +0200, Thomas Schwinge wrote: > Looking at how OpenMP declare simd is handled in the C++ front end, I ran > into it being parsed for PRAGMA_OMP_DECLARE_REDUCTION, which got me > confused. OK to commit the following to un-confuse this, in that > PRAGMA_OACC_* and PRAGMA_OMP_* don't describe what *eventually* is to be > parsed (which (nowadays?) is wrong for PRAGMA_OMP_DECLARE_REDUCTION, > anyway), but instead they describe what *so far* has been parsed.
I think I'd prefer if anything just to change PRAGMA_OMP_DECLARE_REDUCTION to PRAGMA_OMP_DECLARE (as the only case where there is any ambiguity) and nothing else, the rest would be more confusing than it is now. > commit fa557f6ad39992052decb413501c713db8ec59f0 > Author: Thomas Schwinge <tho...@codesourcery.com> > Date: Tue Jun 28 14:12:23 2016 +0200 > > Clarify PRAGMA_OACC_* and PRAGMA_OMP_* > > gcc/c-family/ > * c-pragma.h (enum pragma_kind): Rename PRAGMA_OACC_ENTER_DATA to > PRAGMA_OACC_ENTER, PRAGMA_OACC_EXIT_DATA to PRAGMA_OACC_EXIT, > PRAGMA_OMP_CANCELLATION_POINT to PRAGMA_OMP_CANCELLATION, > PRAGMA_OMP_DECLARE_REDUCTION to PRAGMA_OMP_DECLARE, > PRAGMA_OMP_END_DECLARE_TARGET to PRAGMA_OMP_END. Adjust all > users. Jakub