On 27/05/16 13:51, Thomas Preudhomme wrote:
On Tuesday 24 May 2016 18:00:27 Kyrill Tkachov wrote:
Hi Thomas,
Hi Kyrill,
+/* Nonzero if chip supports Thumb. */
+extern int arm_arch_thumb;
+
Bit of bikeshedding really, but I think a better name would be
arm_arch_thumb1.
This is because we also have the macros TARGET_THUMB and TARGET_THUMB2
where TARGET_THUMB2 means either Thumb-1 or Thumb-2 and a casual reader
might think that arm_arch_thumb means that there is support for either.
Fixed.
Also, please add a simple test that compiles something with -march=armv5
(plus -marm) and checks that __ARM_ARCH_ISA_THUMB is not defined.
Fixed too.
Please find the updated in attachment. ChangeLog entries are now:
*** gcc/ChangeLog ***
2016-05-26 Thomas Preud'homme <thomas.preudho...@arm.com>
* config/arm/arm-protos.h (arm_arch_thumb1): Declare.
* config/arm/arm.c (arm_arch_thumb1): Define.
(arm_option_override): Initialize arm_arch_thumb1.
* config/arm/arm.h (arm_arch_thumb1): Declare.
(TARGET_ARM_ARCH_ISA_THUMB): Use arm_arch_thumb to determine if target
support Thumb-1 ISA.
*** gcc/testsuite/ChangeLog ***
2016-05-26 Thomas Preud'homme <thomas.preudho...@arm.com>
* gcc.target/arm/armv5_thumb_isa.c: New test.
Ok.
Thanks,
Kyrill
Given the renaming I've redone the testing and confirmed that the patch still
works as intended.
Best regards,
Thomas