On 11/27/2015 10:26 AM, Eric Botcazou wrote:

+#ifdef STACK_REGS
+             if (regstack_completed
+                 && REG_P (recog_data.operand[i])
+                 && IN_RANGE (REGNO (recog_data.operand[i]),
+                              FIRST_STACK_REG, LAST_STACK_REG))
+               untracked_operands |= 1 << i;
+#endif

Why not use "op" instead of recog_data.operand[i] here?  Don't this need to be
placed before the conditional call to create_new_chain?

Both good points. Ok with those changes (will retest)?


Bernd

Reply via email to