On 10/19/2015 05:33 AM, Marek Polacek wrote:
+ if (fold_p) + expr = fold_build1_loc (loc, NOP_EXPR, totype, expr); + else + expr = build1_loc (loc, NOP_EXPR, totype, expr);
Rather than duplicate code like this everywhere, maybe we should introduce a maybe_fold_build1_loc macro that takes fold_p as an argument.
Jason