On 07/16/2011 07:37 AM, Dodji Seketeli wrote:
-extern void linemap_init (struct line_maps *);
+void linemap_init (struct line_maps *);
-/* Free a line map set. */
-extern void linemap_free (struct line_maps *);
+/* Free a line map set. This should be called only if maps have NOT
+ been allocated in garbage memory space. */
+void linemap_free (struct line_maps *);
/* Check for and warn about line_maps entered but not exited. */
+void linemap_check_files_exited (struct line_maps *);
-extern void linemap_check_files_exited (struct line_maps *);
+/* Returns TRUE if the line table set tracks token locations accross
+ macro expansion, FALSE otherwise. */
+bool linemap_tracks_macro_expansion_locs_p (struct line_maps *);
/* Return a source_location for the start (i.e. column==0) of
- (physical) line TO_LINE in the current source file (as in the
- most recent linemap_add). MAX_COLUMN_HINT is the highest column
- number we expect to use in this line (but it does not change
- the highest_location). */
-
-extern source_location linemap_line_start
+ (physical) line TO_LINE in the current source file (as in the most
+ recent linemap_add). MAX_COLUMN_HINT is the highest column number
+ we expect to use in this line (but it does not change the
+ highest_location). */
+source_location linemap_line_start
(struct line_maps *set, linenum_type to_line, unsigned int max_column_hint);
Apart from the added declaration, these changes seem like unnecessary
churn; let's avoid reformatting unchanged comments and removing "extern"
from declarations that are correct as they are.
Jason