On Apr 15, 2011, at 2:38 PM, Steven Bosscher wrote:

> On Fri, Apr 15, 2011 at 11:04 AM, Eric Botcazou <ebotca...@adacore.com> wrote:
>> @@ -4938,11 +4938,13 @@ find_split_point (rtx *loc, rtx insn, bool set_src)
>> 
>>    IN_DEST is nonzero if we are processing the SET_DEST of a SET.
>> 
>> +   IN_COND is nonzero if we are on top level of the condition.
>> 
>> "...we are at the top level of a condition."
> 
> And make IN_COND a bool instead of an int?

I think it's better to follow existing format of the function and make IN_COND 
to be of the same type as IN_DEST, i.e.,  an 'int'.  I agree that 'bool' should 
be preferred when adding a new function or significantly rewriting an existing 
one.

--
Maxim Kuvyrkov
Mentor Graphics / CodeSourcery

Reply via email to