https://gcc.gnu.org/g:723e0f724e0c884a31ddf4a688604e7163ed31f2

commit r15-2843-g723e0f724e0c884a31ddf4a688604e7163ed31f2
Author: Jakub Jelinek <ja...@redhat.com>
Date:   Fri Aug 9 09:34:50 2024 +0200

    c-family: Add some more ARRAY_SIZE uses
    
    These two spots were just non-standard, because they divided
    sizeof (omp_pragmas_simd) by sizeof (*omp_pragmas) and not
    the expected sizeof (*omp_pragmas_simd) and so weren't converted
    into ARRAY_SIZE.  Both of the latter sizes are the same though,
    as both arrays have the same type, so this patch doesn't change
    anything but readability.
    
    2024-08-09  Jakub Jelinek  <ja...@redhat.com>
    
            * c-pragma.cc (c_pp_lookup_pragma): Use ARRAY_SIZE in
            n_omp_pragmas_simd initializer.
            (init_pragmas): Likewise.

Diff:
---
 gcc/c-family/c-pragma.cc | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/gcc/c-family/c-pragma.cc b/gcc/c-family/c-pragma.cc
index 25251c2b69f9..ed2a7a00e9eb 100644
--- a/gcc/c-family/c-pragma.cc
+++ b/gcc/c-family/c-pragma.cc
@@ -1565,8 +1565,7 @@ c_pp_lookup_pragma (unsigned int id, const char **space, 
const char **name)
 {
   const int n_oacc_pragmas = ARRAY_SIZE (oacc_pragmas);
   const int n_omp_pragmas = ARRAY_SIZE (omp_pragmas);
-  const int n_omp_pragmas_simd = sizeof (omp_pragmas_simd)
-                                / sizeof (*omp_pragmas);
+  const int n_omp_pragmas_simd = ARRAY_SIZE (omp_pragmas_simd);
   int i;
 
   for (i = 0; i < n_oacc_pragmas; ++i)
@@ -1807,8 +1806,7 @@ init_pragma (void)
        }
       if (flag_openmp || flag_openmp_simd)
        {
-         const int n_omp_pragmas_simd
-           = sizeof (omp_pragmas_simd) / sizeof (*omp_pragmas);
+         const int n_omp_pragmas_simd = ARRAY_SIZE (omp_pragmas_simd);
          int i;
 
          for (i = 0; i < n_omp_pragmas_simd; ++i)

Reply via email to