https://gcc.gnu.org/bugzilla/show_bug.cgi?id=122009

--- Comment #11 from GCC Commits <cvs-commit at gcc dot gnu.org> ---
The master branch has been updated by Gaius Mulley <[email protected]>:

https://gcc.gnu.org/g:328dc7f2dd1ab1e60633647f9a1fb2ec717a9afc

commit r16-4187-g328dc7f2dd1ab1e60633647f9a1fb2ec717a9afc
Author: Gaius Mulley <[email protected]>
Date:   Thu Oct 2 14:36:42 2025 +0100

    PR modula2/122009: Rename local variables to avoid warnings and add const
char

    This patch renames local variables in M2WIDESET.mod to avoid compile time
    warnings.  It also fixes the parameter declaration in BuildEnumerator to
    include the const modifier.

    gcc/m2/ChangeLog:

            PR modula2/122009
            * gm2-compiler/M2GCCDeclare.mod (PrintKnown): Remove.
            * gm2-gcc/m2type.cc (m2type_BuildEnumerator): Add const modifier.
            * gm2-gcc/m2type.def (BuildEnumerator): Use ConstCharStar type.
            * gm2-gcc/m2type.h (m2type_BuildEnumerator): Add const modifier.
            * gm2-libs/M2WIDESET.mod (ShiftLeftByteBit): Rename variable to
            as toIdx.
            Rename variable from as fromIdx.
            (ShiftRightByteBit): Rename variable to as toIdx.
            Rename variable from as fromIdx.
            (RotateLeft): Rename variable to as toIdx.
            Rename variable from as fromIdx.
            (ArithShiftLeftBit): Rename set to setb.
            (ArithShiftRightBit): Rename set to setb.

    Signed-off-by: Gaius Mulley <[email protected]>

Reply via email to