https://gcc.gnu.org/bugzilla/show_bug.cgi?id=118843
--- Comment #4 from Xi Ruoyao <xry111 at gcc dot gnu.org> --- (In reply to chenglulu from comment #3) > I tried to make some changes, and the test went smoothly without any issues. > for (int i = 0; i < N_EVO_FEATURES; i++) > { > builtin_undef (la_evo_macro_name[i]); > > if (la_target.isa.evolution & la_evo_feature_masks[i] > && (la_evo_feature_masks[i] ^ OPTION_MASK_ISA_FRECIPE I suppose "!=" would be more readable than "^". > || TARGET_HARD_FLOAT)) > { > builtin_define (la_evo_macro_name[i]); > > int major = la_evo_version_major[i], > minor = la_evo_version_minor[i]; > > max_v_major = major > max_v_major ? major : max_v_major; > max_v_minor = major == max_v_major > ? (minor > max_v_minor ? minor : max_v_minor) : max_v_minor; > } > }