https://gcc.gnu.org/bugzilla/show_bug.cgi?id=118606
--- Comment #3 from David Binderman <dcb314 at hotmail dot com> --- (In reply to Jakub Jelinek from comment #1) > What is confusing about that? It's a matter of style. Clang considers that some style boundary has been stepped over in the original case. > Is that any different from non-overloaded > operator? > We have > combine.cc: && nonzero_bits (XEXP (varop, 1), int_result_mode) >> > count == 0 > combine.cc: && const_op >> i == 0 > simplify-rtx.cc: if (mask >> count == INTVAL (trueop1) I'd add extra () for clarity in all these cases too. I've seen too many cases where junior programmers get precedence wrong.