https://gcc.gnu.org/bugzilla/show_bug.cgi?id=118011

--- Comment #3 from GCC Commits <cvs-commit at gcc dot gnu.org> ---
The master branch has been updated by Jakub Jelinek <ja...@gcc.gnu.org>:

https://gcc.gnu.org/g:18f0b7d5f370c47633837e935f8a6e1b8616b56b

commit r15-6252-g18f0b7d5f370c47633837e935f8a6e1b8616b56b
Author: Jakub Jelinek <ja...@redhat.com>
Date:   Sat Dec 14 11:25:08 2024 +0100

    opts: Use OPTION_SET_P instead of magic value 2 for -fshort-enums default
[PR118011]

    The magic values for default (usually -1 or sometimes 2) for some options
    are from times we haven't global_options_set, I think we should eventually
    get rid of all of those.

    The PR is about gcc -Q --help=optimizers reporting -fshort-enums as
    [enabled] when it is disabled.
    For this the following patch is just partial fix; with explicit
    gcc -Q --help=optimizers -fshort-enums
    or
    gcc -Q --help=optimizers -fno-short-enums
    it already worked correctly before, with this patch it will report
    even with just
    gcc -Q --help=optimizers
    correct value on most targets, except 32-bit arm with some options or
    defaults, so I think it is a step in the right direction.

    But, as I wrote in the PR, process_options isn't done before --help=
    and even shouldn't be in its current form where it warns on some option
    combinations or errors or emits sorry on others, so I think ideally
    process_options should have some bool argument whether it is done for
    --help= purposes or not, if yes, not emit warnings and just adjust the
    options, otherwise do what it currently does.

    2024-12-14  Jakub Jelinek  <ja...@redhat.com>

            PR c/118011
    gcc/
            * opts.cc (init_options_struct): Don't set opts->x_flag_short_enums
to
            2.
            * toplev.cc (process_options): Test !OPTION_SET_P
(flag_short_enums)
            rather than flag_short_enums == 2.
    gcc/ada/
            * gcc-interface/misc.cc (gnat_post_options): Test
            !OPTION_SET_P (flag_short_enums) rather than flag_short_enums == 2.

Reply via email to