https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79147
Bug ID: 79147 Summary: Uselsss _GLIBCXX_PACKAGE_* macros in <bits/c++config.h> Product: gcc Version: 6.3.0 Status: UNCONFIRMED Severity: normal Priority: P3 Component: libstdc++ Assignee: unassigned at gcc dot gnu.org Reporter: redi at gcc dot gnu.org Target Milestone: --- The libstdc++ headers define these macros: /* Define to the address where bug reports for this package should be sent. */ #define _GLIBCXX_PACKAGE_BUGREPORT "" /* Define to the full name of this package. */ #define _GLIBCXX_PACKAGE_NAME "package-unused" /* Define to the full name and version of this package. */ #define _GLIBCXX_PACKAGE_STRING "package-unused version-unused" /* Define to the one symbol short name of this package. */ #define _GLIBCXX_PACKAGE_TARNAME "libstdc++" /* Define to the version of this package. */ #define _GLIBCXX_PACKAGE__GLIBCXX_VERSION "version-unused" These are all pretty useless, but the last one is particularly silly. It should probably by _GLIBCXX_PACKAGE_VERSION, but the sed rule in include/Makefile.am modifies it twice: sed -e 's/HAVE_/_GLIBCXX_HAVE_/g' \ -e 's/PACKAGE/_GLIBCXX_PACKAGE/g' \ -e 's/VERSION/_GLIBCXX_VERSION/g' \ -e 's/WORDS_/_GLIBCXX_WORDS_/g' \ -e 's/ICONV_CONST/_GLIBCXX_ICONV_CONST/g' \ -e '/[ ]_GLIBCXX_LONG_DOUBLE_COMPAT[ ]/d' \ < ${CONFIG_HEADER} >> $@ ;\ If we did s/PACKAGE_/_GLIBCXX_PACKAGE_/ instead then it would give a more sensible result. We should also consider replacing this whole thing with something based on AX_PREFIX_CONFIG_H instead, so everything in the auto-generated config.h gets