http://gcc.gnu.org/bugzilla/show_bug.cgi?id=52205
--- Comment #9 from Eric Botcazou <ebotcazou at gcc dot gnu.org> 2012-02-14 22:04:35 UTC --- > I'm currently doing so, and preliminary results look good. I've got a > couple of comments on the patch as-is which I find harder than necessary > to read/understand: > > * It uses far too magic numbers unnecessarily and/or without > explanation. E.g. looking for the caller frame with hardcoded offsets > (cuh_patter, sah_address) is unnecessary: just use struct frame in > <sys/frame.h> for that, where fr_savfp is the saved frame pointer at > that exact offset. > > * All the patterns should be acompanied by the disassembly to make it > easier to compare with that you see e.g. in a debugger. > > * Talking of Solaris 8 in Solaris Containers is unnecessary and > incomplete: this is just the Solaris 8 alternate thread library (in > /usr/lib/lwp) which is copied over /usr/lib/libthread.so.1 when > booting the branded zone, but is also used by gcc on Solaris 8 by > default. This alternate thread library became the default in Solaris > 9, thus they are the same. Fine with me (I won't make any of these changes myself though).