>locore.s includes:
>#define ALLOCPAGES(foo) \
> movl R(physfree), %esi ; \
> movl $((foo)*PAGE_SIZE), %eax ; \
> addl %esi, %eax ; \
> movl %eax, R(physfree) ; \
> movl %esi, %edi ; \
> movl $((foo)*PAGE_SIZE),%ecx ; \
> xorl %eax,%eax ; \
> cld ; \
> rep ; \
> stosb
>
>
>might it be a very slight optimisation to change this to:
>#define ALLOCPAGES(foo) \
> movl R(physfree), %esi ; \
> movl $((foo)*PAGE_SIZE), %eax ; \
> movl %eax, %ecx ; \
> addl %esi, %eax ; \
> movl %eax, R(physfree) ; \
> movl %esi, %edi ; \
> xorl %eax,%eax ; \
> cld ; \
> rep ; \
> stosb
>
>??
Improvement in what way?
Readability? I don't think so.
Performance? This macro is only used in the initial bootstrap of the
kernel.
...changing it might save a few bytes, however.
-DG
David Greenman
Co-founder, The FreeBSD Project - http://www.freebsd.org
President, TeraSolutions, Inc. - http://www.terasolutions.com
Pave the road of life with opportunities.
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message