Roy Golan has posted comments on this change.

Change subject: engine: VdcActionUtils: Remove reflection
......................................................................


Patch Set 2:

(1 comment)

....................................................
File 
backend/manager/modules/common/src/main/java/org/ovirt/engine/core/common/businessentities/BusinessEntityWithStatus.java
Line 4: 
Line 5: /**
Line 6:  * A {@link }BusinessEntity} with a status enum.
Line 7:  */
Line 8: public interface BusinessEntityWithStatus<ID extends Serializable, 
Status extends Enum<?>> extends BusinessEntity<ID> {
great. I did something similar with Identifiable and Nameable (Statusable isn't 
a good name is it?...)

<ID,Status> is a bit confusing. couldn't we settle with just Status as a 
generic parameter and let an entity extend each interface when needed?

 class ExternalVM implemets BusinessEntity<Integer>, 
BusinessEntityWithStatus<VmStatus>
  
 ...


its looser and more readable
Line 9:     Status getStatus();
Line 10: 
Line 11:     void setStatus(Status status);


-- 
To view, visit http://gerrit.ovirt.org/18855
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I4b1c3857e1237bef9fc1af96e96043677b2debd4
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Alissa Bonas <abo...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Mike Kolesnik <mkole...@redhat.com>
Gerrit-Reviewer: Roy Golan <rgo...@redhat.com>
Gerrit-Reviewer: Tal Nisan <tni...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to