Arik Hadas has posted comments on this change. Change subject: core: cleanup in MoveOrCopyDiskCommand ......................................................................
Patch Set 2: (1 comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyDiskCommand.java Line 53: @Override Line 54: protected void setActionMessageParameters() { Line 55: addCanDoActionMessage(getParameters().getOperation() == ImageOperation.Copy ? Line 56: VdcBllMessages.VAR__ACTION__COPY Line 57: : VdcBllMessages.VAR__ACTION__MOVE); I agree when it makes the code complicated (as it is in RunVmCommand#getAuditLogTypeValue, at the else clause of the EXECUTE case), but here it's a classic place to use it to simplify the code. I understand that it is a matter of taste though.. Line 58: addCanDoActionMessage(VdcBllMessages.VAR__TYPE__VM_DISK); Line 59: } Line 60: Line 61: @Override -- To view, visit http://gerrit.ovirt.org/18007 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Id28853bca622bf19ef66c983fa2d7ea38b943fa7 Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches