Maor Lipchuk has posted comments on this change. Change subject: core: InitVdsOnUp - flow fixes ......................................................................
Patch Set 1: (1 comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InitVdsOnUpCommand.java Line 213: private EventResult runConnectHostToPoolEvent(final Guid storagePoolId, final VDS vds) { Line 214: EventResult result = new EventResult(true, EventType.VDSCONNECTTOPOOL); Line 215: StoragePool storagePool = getStoragePoolDAO().get(storagePoolId); Line 216: StorageDomain masterDomain = getStorageDomainDAO().getStorageDomainByTypeAndPool(storagePoolId, StorageDomainType.Master); Line 217: boolean masterDomainInactiveOrUnknown = masterDomain.getStatus() == StorageDomainStatus.InActive I would rename the parameter to isMasterDomainInactiveOrUnknown, the current parameter name could be confusing since it is already determines that the master domain is already inactive or unknown.... I would also consider to extract this to a method Line 218: || masterDomain.getStatus() == StorageDomainStatus.Unknown; Line 219: try { Line 220: runVdsCommand(VDSCommandType.ConnectStoragePool, Line 221: new ConnectStoragePoolVDSCommandParameters(vds.getId(), storagePoolId, -- To view, visit http://gerrit.ovirt.org/18165 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I61fcc58be133efdecf264c22015609f6ee3ed942 Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Liron Ar <lara...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Liron Ar <lara...@redhat.com> Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> Gerrit-Reviewer: Tal Nisan <tni...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches