Tomas Jelinek has posted comments on this change. Change subject: webadmin: Adds warning when upgrading cluster level ......................................................................
Patch Set 1: (2 comments) .................................................... File frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/clusters/ClusterListModel.java Line 1025: } else { Line 1026: throw new IllegalArgumentException("The return value should be ArrayList<VDS> or VdcQueryReturnValue with return value ArrayList<VDS>"); //$NON-NLS-1$ Line 1027: } Line 1028: Line 1029: boolean result = false; I would use some more descriptive name than result - like "foundNonResponsiveHost" Line 1030: for (VDS host : hosts) { Line 1031: if (VDSStatus.NonResponsive == host.getStatus()) { Line 1032: result = true; Line 1033: break; Line 1026: throw new IllegalArgumentException("The return value should be ArrayList<VDS> or VdcQueryReturnValue with return value ArrayList<VDS>"); //$NON-NLS-1$ Line 1027: } Line 1028: Line 1029: boolean result = false; Line 1030: for (VDS host : hosts) { NPE vulnerability - the hosts can be null Line 1031: if (VDSStatus.NonResponsive == host.getStatus()) { Line 1032: result = true; Line 1033: break; Line 1034: } -- To view, visit http://gerrit.ovirt.org/17958 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I88f47dd84c030bcd723f41c7973c4dae32df9f2e Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Martin Peřina <mper...@redhat.com> Gerrit-Reviewer: Alona Kaplan <alkap...@redhat.com> Gerrit-Reviewer: Martin Peřina <mper...@redhat.com> Gerrit-Reviewer: Tomas Jelinek <tjeli...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches