Michael Pasternak has posted comments on this change.

Change subject: restapi: add memory attribute to snapshot
......................................................................


Patch Set 20: I would prefer that you didn't submit this

(3 inline comments)

arik,

please also describe this feature under /capabilities.features

thanks.

....................................................
File 
backend/manager/modules/restapi/interface/definition/src/main/resources/api.xsd
Line 2528:         <xs:sequence>
Line 2529:           <xs:element ref="vm" minOccurs="0"/>
Line 2530:           <xs:element name="date" type="xs:dateTime" minOccurs="0"/>
Line 2531:           <xs:element name="snapshot_status" type="xs:string" 
minOccurs="0"/>
Line 2532:           <xs:element name="snapshot_memory" type="xs:boolean" 
minOccurs="0"/>
this name is ambiguous, i'd call it persist_memorystate or similar
Line 2533:           <!-- Also a rel="prev" link -->
Line 2534:         </xs:sequence>
Line 2535:       </xs:extension>
Line 2536:     </xs:complexContent>


....................................................
File 
backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
Line 583:       parameterType: Snapshot
Line 584:       signatures:
Line 585:       - mandatoryArguments: {snapshot.description: 'xs:string'}
Line 586:         optionalArguments:
Line 587:           snapsht_memory: xs:boolean
this option should be a part of the snapshot. e.g snapshot.X
Line 588:     urlparams: {}
Line 589:     headers:
Line 590:       Content-Type: {value: application/xml|json, required: true}
Line 591:       Expect: {value: 201-created, required: false}


....................................................
File 
backend/manager/modules/restapi/types/src/main/java/org/ovirt/engine/api/restapi/types/SnapshotMapper.java
Line 22:             model.setType(map(entity.getType(), null));
Line 23:         }
Line 24:         if (entity.getMemoryVolume() != null) {
Line 25:             
model.setSnapshotMemory(!entity.getMemoryVolume().isEmpty());
Line 26:         }
shouldn't this be bi-directional? (i.e server->client, server<-client)
Line 27:         return model;
Line 28:     }
Line 29: 
Line 30:     @Mapping(from = 
org.ovirt.engine.core.common.businessentities.Snapshot.SnapshotType.class, to = 
String.class)


-- 
To view, visit http://gerrit.ovirt.org/15186
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id04e7944c4ee58cc05aafc95b6bfc451742b4eff
Gerrit-PatchSet: 20
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <aha...@redhat.com>
Gerrit-Reviewer: Arik Hadas <aha...@redhat.com>
Gerrit-Reviewer: Michael Pasternak <mpast...@redhat.com>
Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to