Yair Zaslavsky has posted comments on this change. Change subject: core: RunVmCommand.canDoAction clean-up (6) ......................................................................
Patch Set 5: (1 inline comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/VmRunHandler.java Line 57: * @param snapshotsValidator Line 58: * @param vmPropsUtils Line 59: * @return true if the given VM can run with the given properties, false otherwise Line 60: */ Line 61: public boolean canRunVm(VM vm, ArrayList<String> message, RunVmParams runParams, IMHO, could be nicer if we can break this method into smaller parts, but not critical. Line 62: VdsSelector vdsSelector, SnapshotsValidator snapshotsValidator) { Line 63: boolean retValue = true; Line 64: Line 65: storage_pool sp = getStoragePoolDAO().get(vm.getStoragePoolId()); -- To view, visit http://gerrit.ovirt.org/13402 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I297c9afba655c38ffdd870f61b1967732a712912 Gerrit-PatchSet: 5 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com> Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: Laszlo Hornyak <lhorn...@redhat.com> Gerrit-Reviewer: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: ofri masad <oma...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches