Alona Kaplan has posted comments on this change. Change subject: webadmin: Rewrote arranging of NICs in Host/Networks subtab ......................................................................
Patch Set 6: (2 inline comments) .................................................... File frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/hosts/HostInterfaceListModel.java Line 518: private void classifyNics(List<Bond> nonEmptyBonds, Line 519: List<Nic> independentNics, Line 520: Map<String, List<Nic>> bondToNics, Line 521: Map<String, List<Vlan>> nicToVlans) { Line 522: for (VdsNetworkInterface i : getOriginalItems()) { I think "I" is not a good name. Maybe change to "interface" Line 523: if (i instanceof Bond) { Line 524: nonEmptyBonds.add((Bond) i); Line 525: } else if (i instanceof Nic) { Line 526: if (i.getBondName() == null) { Line 533: nicList.add((Nic) i); Line 534: bondToNics.put(i.getBondName(), nicList); Line 535: } Line 536: } Line 537: } else { To be more readable I think it should be more specific- if (i instance of Vlan) Line 538: String nameWithoutVlan = i.getName().substring(0, i.getName().lastIndexOf('.')); Line 539: if (nicToVlans.containsKey(nameWithoutVlan)) { Line 540: nicToVlans.get(nameWithoutVlan).add((Vlan) i); Line 541: } else { -- To view, visit http://gerrit.ovirt.org/12000 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I0b464cc023282ceab868230a1c31638ebe75de4d Gerrit-PatchSet: 6 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Lior Vernia <lver...@redhat.com> Gerrit-Reviewer: Alona Kaplan <alkap...@redhat.com> Gerrit-Reviewer: Lior Vernia <lver...@redhat.com> Gerrit-Reviewer: Moti Asayag <masa...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches