Doron Fediuck has posted comments on this change.

Change subject: tools: notifier - add validation to mail type properties
......................................................................


Patch Set 2: (1 inline comment)

Good progress, but a few nits / questions inline.

....................................................
File 
backend/manager/tools/engine-notifier/engine-notifier-resources/src/main/resources/notifier.sh
Line 22: }
Line 23: 
Line 24: check_email_format() {
Line 25:     #exit with a message if the property is not in user@domain format
Line 26:     if [[ ! ${!1} == *@* ]] ;  then
Why use ! and ==? 
Will it not be more readable to use-

[[  ${!1} != *@* ]] ; ?

As for the regex, what will happen if I use "doron@" ?
Line 27:        die "Error: $1 must be of the form user@domain"
Line 28:     fi
Line 29: }
Line 30: 


--
To view, visit http://gerrit.ovirt.org/10775
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I652d6b7aa9ca34192d6892174bf57b11335cb98a
Gerrit-PatchSet: 2
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Noam Slomianko <nslom...@redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com>
Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com>
Gerrit-Reviewer: Noam Slomianko <nslom...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: ofri masad <oma...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to