Roy Golan has posted comments on this change. Change subject: core: Removal of DNS root from host name ......................................................................
Patch Set 1: Looks good to me, approved (1 inline comment) .................................................... File backend/manager/modules/utils/src/main/java/org/ovirt/engine/core/utils/dns/DnsSRVLocator.java Line 324: //Remove the "root DNS" part from the host name Line 325: //if exists as "." at the end of the host name Line 326: if (host.lastIndexOf(".") == host.length() -1) { Line 327: host = host.substring(0, host.length() - 1); Line 328: } minor and for you to choose host.charAt(host.length-1) == '.' seems more readable. Line 329: StringBuilder sb = new StringBuilder(host); Line 330: sb.append(":").append(port); Line 331: return new SrvRecord(priority, weight, sb.toString()); Line 332: } catch (InputMismatchException ex) { -- To view, visit http://gerrit.ovirt.org/11335 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I14ffafec4853f23a3bfa50793febafbbf97321f2 Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Yair Zaslavsky <yzasl...@redhat.com> Gerrit-Reviewer: Ravi Nori <rn...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches