Roy Golan has posted comments on this change. Change subject: core: fix run once starts with wrong display type ......................................................................
Patch Set 2: (1 inline comment) .................................................... File backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VmInfoBuilder.java Line 70: Line 71: /** Line 72: * Add video device according to the given display type Line 73: */ Line 74: private void addVideoCardAccordingToTheRequestedDisplayType(DisplayType displayType) { method name too long. could be simplified to getVideoCardByType or similar as the javadoc already has the explanation can you make the addFromDb.. method use also this block to keep it DRY? Line 75: XmlRpcStruct struct = new XmlRpcStruct(); Line 76: // create a monitor as an unmanaged device Line 77: struct.add(VdsProperties.Type, VmDeviceType.VIDEO.getName()); Line 78: struct.add(VdsProperties.Device, displayType.getVmDeviceType().getName()); -- To view, visit http://gerrit.ovirt.org/10537 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I635307847edf764b174230203ee355987b948ce4 Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Arik Hadas <aha...@redhat.com> Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com> Gerrit-Reviewer: Roy Golan <rgo...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches