Allon Mureinik has posted comments on this change. Change subject: [WIP] engine: User queries improvements ......................................................................
Patch Set 9: Looks good to me, but someone else must approve (5 inline comments) some minor inline issues, and a major issue with the name. Other than that - OK. .................................................... File backend/manager/dbscripts/create_functions.sql Line 42: Line 43: CREATE OR REPLACE FUNCTION fnSplitterUuid(ids TEXT) RETURNS SETOF UUID AS Line 44: $function$ Line 45: BEGIN Line 46: IF ids != '' THEN Is this if still necessary? Line 47: RETURN QUERY Line 48: SELECT CAST(regexp_split_to_table(ids, ',') AS UUID); Line 49: END IF; Line 50: END; $function$ .................................................... File backend/manager/dbscripts/create_views.sql Line 779: AS Line 780: Line 781: SELECT permissions.id as id, permissions.role_id as role_id, permissions.ad_element_id as ad_element_id, permissions.object_id as object_id, permissions.object_type_id as object_type_id, Line 782: roles.name as role_name, roles.role_type as role_type, roles.allows_viewing_children as allows_viewing_children Line 783: FROM permissions INNER JOIN please move the INNER JOIN to a new line an indent proprely. Line 784: roles ON permissions.role_id = roles.id; Line 785: Line 786: Line 787: -- .................................................... File backend/manager/dbscripts/multi_level_administration_sp.sql Line 264: Line 265: END; $procedure$ Line 266: LANGUAGE plpgsql; Line 267: Line 268: Create or replace FUNCTION GetAllRolesByUserIdAndGroupIds (v_user_id UUID, v_group_ids text) why add this redundant tab? Line 269: RETURNS SETOF roles Line 270: AS $procedure$ Line 271: BEGIN Line 272: RETURN QUERY SELECT roles.* .................................................... Commit Message Line 7: [WIP] engine: User queries improvements Line 8: Line 9: The following patch contains two improvements: Line 10: 1. Removed unneeded calls to some functions at permissions_view, by creating the small_permissions_view - Line 11: permissions_view should be used for UI purposes , for engine/internal permission check, small_permissions_view should be used. Please find a better name than "small_permissions_view". How about "internal_permissions_view"? Line 12: 2. Introduction of new splitter function. Line 13: Line 14: With multiple paragraphs if necessary. Line 15: Line 10: 1. Removed unneeded calls to some functions at permissions_view, by creating the small_permissions_view - Line 11: permissions_view should be used for UI purposes , for engine/internal permission check, small_permissions_view should be used. Line 12: 2. Introduction of new splitter function. Line 13: Line 14: With multiple paragraphs if necessary. please remove Line 15: Line 16: Bug-Url: https://bugzilla.redhat.com/880969 Line 17: Change-Id: I62fa797fbf286513183f0a3c4409ce79bec35342 Line 18: Signed-off-by: Michael Kublin <mkub...@redhat.com> -- To view, visit http://gerrit.ovirt.org/9825 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I62fa797fbf286513183f0a3c4409ce79bec35342 Gerrit-PatchSet: 9 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com> Gerrit-Reviewer: Eli Mesika <emes...@redhat.com> Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com> Gerrit-Reviewer: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Moti Asayag <masa...@redhat.com> Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches