Allon Mureinik has posted comments on this change. Change subject: core: ImportVm cleanup: iterate maps values() ......................................................................
Patch Set 4: (1 inline comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/ImportVmCommand.java Line 603: if (getParameters().isImportAsNewEntity()) { Line 604: disk.setId(Guid.NewGuid()); Line 605: disk.setImageId(Guid.NewGuid()); Line 606: for (DiskImage currDisk : diskList) { Line 607: currDisk.setId(disk.getId()); @laravot: The last disk in diskList is disk - so there will be no change (setting the disk's ID with itself. I think this is slightly more readable, but am open to other opinions. Line 608: } Line 609: } Line 610: disk.setcreation_date(new Date()); Line 611: BaseImagesCommand.saveImage(disk); -- To view, visit http://gerrit.ovirt.org/9616 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I687810d5619603aab135a7d5d8e8fcef11685e9a Gerrit-PatchSet: 4 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Alissa Bonas <abo...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Ayal Baron <aba...@redhat.com> Gerrit-Reviewer: Daniel Erez <de...@redhat.com> Gerrit-Reviewer: Liron Aravot <lara...@redhat.com> Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com> Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches