Juan Hernandez has posted comments on this change. Change subject: bootstrap: detach OVirtUpgrader from VdsInstaller into OVirtNodeUpgrade ......................................................................
Patch Set 10: I don't consider myself a "pure java developer", rather a developer that happens to be using Java at the moment, and I do understand what you try to do, but I think it is wrong. The fact that the Java coding conventions document has been written 15 years ago doesn't make it useless, on the contrary, during these 15 years it has proven to be very useful to make Java coding consistent across different projects, which is a great asset. I have been reading your arguments in favour of the convention that you propose and I think they aren't strong: * You say that the _ needs to be used in order to signal that a class field or method is private. This is not needed because the Java language already has the private access modifier just for that purpose. In other languages that lack this capability it might be convenient, but not in Java. * You say that the s_ needs to be used in order to signal that a class field or method is static. This is not needed because the Java language already has the static access modifier. Again, other languages may need this, but not Java. * You say that the _ and s_ conventions help avoid shadowing members with local variables. For methods this is completely meaningless. For fields it could be useful in the situation where one names a parameter or local variable with the same name that a field, but this is already solved in Java using the "this" prefix for normal fields or the name of the class for static fields, there is no need to invent a new convention. * You say that the _ and s_ conventions help reviewing patches and working with gerrit, that you need to figure out from the name of an item what is it scope, without looking at its declaration. If this were true you would need to include in the name of the variable indications of the access level, the class where they are declared, the type, etc. Why is the access level more important than the type, or the class where the member is declared, or the initial value? It isn't, and we are not going to use conventions to indicate all this properties of a field or method: they are part of the declaration, go and look at it, that is its purpose. * You say that tools like syntax highlight (and other goodies) in IDEs are not important. I understand that some people might prefer to use plain editors to work with code, that is ok, but that shouldn't mean that code has to be complicated for the benefit of the few people that don't use IDEs. * You say that Java developers are primitive and they are not used to work with patches, code review and tools like git and gerrit. This is not true. Ask the developers of gerrit why they don't use any naming convention like this in their source code, it won't certainly be because they are not used to work with git or patch review. The fact that you forced these conventions in the hostinstall package regardless of the suggestions of the reviewers is not a valid argument. -- To view, visit http://gerrit.ovirt.org/9174 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Iff19fdb9f717d424f23bc5d4e5a8df8fce8a58bf Gerrit-PatchSet: 10 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Alon Bar-Lev <alo...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com> Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com> Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com> Gerrit-Reviewer: Douglas Schilling Landgraf <dougsl...@redhat.com> Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com> Gerrit-Reviewer: Shireesh Anjal <san...@redhat.com> Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches