Alon Bar-Lev has posted comments on this change.

Change subject: bootstrap: detach OVirtUpgrader from VdsInstaller into 
OVirtNodeUpgrade
......................................................................


Patch Set 3: (1 inline comment)

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/InstallerMessages.java
Line 76:         }
Line 77:         return error;
Line 78:     }
Line 79: 
Line 80:     private boolean _postOldXmlFormat(String message) {
This document *DOES* not refer to naming CONVENTION of a complete solution.

The variable name is a variable name postOldXmlFormat, the _ mark it private.

So it follows the standard, with convention. I won't start this discussion all 
over, but this convention makes conflicts between class scope and local scope 
disappear, it also allows you to know what belongs to the interface and what 
not, and it also provides you with eye catcher during review that a variable is 
not local to function.

And it does confirm with the code convention you quoted, its just adds 
attribute at prefix, so that the code convention follows this attribute.

The following indeed clearly violates the 'generic' code convention:

 void f(void) {
     String _myVariablel
 }

But this is not the case.
Line 81:         boolean error = false;
Line 82:         XmlDocument doc = new XmlDocument();
Line 83:         doc.LoadXml(message);
Line 84:         XmlNode node = doc.ChildNodes[0];


--
To view, visit http://gerrit.ovirt.org/9174
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Iff19fdb9f717d424f23bc5d4e5a8df8fce8a58bf
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com>
Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com>
Gerrit-Reviewer: Douglas Schilling Landgraf <dougsl...@redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com>
Gerrit-Reviewer: Shireesh Anjal <san...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to