Omer Frenkel has posted comments on this change.

Change subject: core: cleanup in EventVmStatsRefresher (2)
......................................................................


Patch Set 3:

(2 comments)

https://gerrit.ovirt.org/#/c/42466/3/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java
File 
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsBrokerObjectsBuilder.java:

Line 2188:     }
Line 2189: 
Line 2190:     /**
Line 2191:      * Build VmDynamic from event we get from VDSM upon status change
Line 2192:      * @param vmDynamic - base dynamic data, values which are not 
included in the
i would rename to baseVmDynamic, maybe also note it is not modified
Line 2193:      * events will be taken from it.
Line 2194:      * @param xmlRpcStruct - map from VDSM
Line 2195:      * @return cloned VmDynamic with values received from event
Line 2196:      */


Line 2221: 
Line 2222:         return clonedVmDynamic;
Line 2223:     }
Line 2224: 
Line 2225:     public static Double getNotifyTimeFromVmStatusEvent(Map<String, 
Object> xmlRpcStruct) {
this is not just get because it removes from the map, so better rename to 
removeNotify..
Line 2226:         Object notifyTime = 
xmlRpcStruct.remove(VdsProperties.notify_time);
Line 2227:         if (Long.class.isInstance(notifyTime)) {
Line 2228:             return ((Long) notifyTime).doubleValue();
Line 2229:         }


-- 
To view, visit https://gerrit.ovirt.org/42466
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I1f3cc490ad7c69877d97e8c01428c914bb81472f
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Arik Hadas <aha...@redhat.com>
Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com>
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Michal Skrivanek <mskri...@redhat.com>
Gerrit-Reviewer: Omer Frenkel <ofren...@redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczew...@gmail.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to